[Soekris] Net 5501-70 Dead With Red Flashing Error Light

andrew fabbro andrew at fabbro.org
Thu Jun 18 19:34:22 CEST 2015


Revisiting this 5501-70...I subsequently got a new power supply based
on a suggestion here.  Specifically this one from Soekris:

http://soekris.com/products/psu/psu-12v-3-0a-world.html

What I see now is that it boots fine and I was able to install OpenBSD
via pxeboot, but subsequently it fails when booting from CF, as shown
below.  I did try a different CF card and it installed and booted a
couple times but then went back to this same error.  If I boot
diskless into a ramdisk, I'm able to mount the CF card filesystems
just fine and read from them - every time - so I'm really confused and
can only assume there's something bad in the CF controller, or the way
it's initialized at boot.

I'm wondering:

(1) if the POST is right...looks strange between 'r' and 't'.  It
consistently shows that.

(2) If there is any significance to the '+' and '*' after the 'hd0'

(3) Any other settings I should look at?  As I said, after install, it
booted successfully a couple times often the CF card before getting
into the state below, and now it consistently boots (or rather fails
to boot) with those errors.  Boot from F0 (network) is fine.




POST: 012345689bcefghips1234ajklnopqr,,,tvwxy

comBIOS ver. 1.33c 20080626  Copyright (C) 2000-2008 Soekris Engineering.

net5501

0512 Mbyte Memory                        CPU Geode LX 500 Mhz

Pri Mas  CF_Card                         LBA Xlt 971-255-63  7807 Mbyte

Slot   Vend Dev  ClassRev Cmd  Stat CL LT HT  Base1    Base2   Int
-------------------------------------------------------------------
0:01:2 1022 2082 10100000 0006 0220 08 00 00 A0000000 00000000 10
0:06:0 1106 3053 02000096 0117 0210 08 40 00 0000E101 A0004000 11
0:07:0 1106 3053 02000096 0117 0210 08 40 00 0000E201 A0004100 05
0:08:0 1106 3053 02000096 0117 0210 08 40 00 0000E301 A0004200 09
0:09:0 1106 3053 02000096 0117 0210 08 40 00 0000E401 A0004300 12
0:17:0 13A3 0020 0B400000 0116 0280 08 40 00 A0005000 A0006000 15
0:20:0 1022 2090 06010003 0009 02A0 08 40 80 00006001 00006101
0:20:2 1022 209A 01018001 0005 02A0 08 00 00 00000000 00000000
0:21:0 1022 2094 0C031002 0006 0230 08 00 80 A0010000 00000000 07
0:21:1 1022 2095 0C032002 0006 0230 08 00 00 A0011000 00000000 07

 1 Seconds to automatic boot.   Press Ctrl-P for entering Monitor.
Using drive 0, partition 3.
Loading.....
probing: pc0 com0 com1 pci mem[639K 511M a20=on]
disk: hd0+*
>> OpenBSD/i386 BOOT 3.26
open(hd0a:/etc/boot.conf): Unknown error: code 100
boot>
cannot open hd0a:/etc/random.seed: Unknown error: code 100
booting hd0a:/bsd: open hd0a:/bsd: Unknown error: code 100
 failed(100). will try /bsd
boot>
cannot open hd0a:/etc/random.seed: Invalid argument
booting hd0a:/bsd: open hd0a:/bsd: Invalid argument
 failed(22). will try /bsd
Turning timeout off.
boot>



On Tue, May 5, 2015 at 4:32 PM, andrew fabbro <andrew at fabbro.org> wrote:
> I have a Soekris Net 5501-70.  I bought it second-hand and it's worked fine
> for about six months.
>
> A few days ago it stopped responding and upon checking it, I find the power
> and error lights are both flashing rapidly.
>
> It doesn't respond on its serial port (not even POST messages at boot).  I
> tried removing both the CF card and the hard drive and this did not make any
> difference.
>
> Here is a video of the lights: https://www.youtube.com/watch?v=CmOKcBwx3FM
>
> This seems similar to:
> http://lists.soekris.com/pipermail/soekris-tech/2009-April/015734.html
>
> Any thoughts or hope?
>
>
> --
> andrew fabbro
> andrew at fabbro.org
> blog: https://raindog308.com
>



-- 
andrew fabbro
andrew at fabbro.org
blog: https://raindog308.com


More information about the Soekris-tech mailing list