[Soekris] NET6501 Booting Debian with LILO

Dean Maluski dean at n1ety.com
Wed May 29 12:57:59 CEST 2013



On Sat, 2013-05-25 at 09:40 -0400, Dean Maluski wrote:
> Running 2 6501's in vehicles on inverters. On the average I've been
> dropping to GRUB prompt 1 out of 7 reboots which is too often in my
> particular application!
> Last night I found this excellent write-up on how to convert Debian
> installs to LILO.
> http://users.wowway.com/~zlinuxman/lilo.htm
> 
> Below is my manual build of /etc/lilo.conf running on NET6501 with one
> onboard SSD drive.
> If I leave the 
> append="console=ttyS0,9600"
> off it boots in about 10 seconds after the LILO 4 second timeout.
> With append I get more feedback on serial port than I did with GRUB and
> it takes about 30 seconds to boot. Not necessarily a problem for me just
> an observation.
> What was a problem was Grub dropping out and having to hit the reset
> button.
> Too soon to tell if my troubles are in the past. I hope so!
> 
> I'm pleased to report that since replacing Grub with Lilo I haven't had a single issue and I've intentionally booted and rebooted excessively over the last 3 or 4 days.

> 
> #/etc/lilo.conf
> #
> # global options
> #
> boot=/dev/disk/by-id/ata-TS4GMSA500_20120919A37292131654
> compact
> default=Linux
> delay=40
> install=text
> large-memory
> lba32
> root="UUID=c333814a-ef3d-41be-b873-d7ed752f8216"
> read-only
> vga=normal
> #
> # per-image options
> #
> image=/boot/vmlinuz-2.6.32-5-686
> 	label=Linux
> 	initrd=/boot/initrd.img-2.6.32-5-686
> 	append="console=ttyS0,9600"
> 
> 
> 
> 
> 
> _______________________________________________
> Soekris-tech mailing list
> Soekris-tech at lists.soekris.com
> http://lists.soekris.com/mailman/listinfo/soekris-tech
> 




More information about the Soekris-tech mailing list