[Soekris] - Net5501 Can't see on serial port the boot and shutdown Process

pierrick karadoc at free.fr
Thu Oct 2 17:47:59 UTC 2008


Hello all!

I did an install of SmoothWall Express 3 on a Soekris Net5501. This box
doesn't have a display port so I used the serial port (COM1) to setup my SWE

I did these customizations:
BIOS of Soekris for the COM1 19200
Modify the etc/lilo.conf :
Code:
----------------------------------------------------------------------------
-----
boot=/dev/hda4
map=/boot/map
install=/boot/boot-bmp.b
prompt
timeout=30
lba32
default=SmoothWall
read-only
root=/dev/hda4
bmp-colors=13,,12;14,,12
bmp-table=100p,348p,1,3,
bmp-timer=74,29,;,,
append="ramdisk_size=8192 no-scroll panic=30, console=tty0 
console=ttyS0,19200"
image=/boot/vmlinuz-2.6.16.53
   initrd=/boot/initrd-2.6.16.53.gz
   append="console=tty0 console=ttyS0,19200"
   label=SmoothWall

----------------------------------------------------------------------------
-----
Modify the etc/inittab :
Code:
----------------------------------------------------------------------------
-----
id:3:initdefault:

l0:0:wait:/etc/rc.d/rc.halt halt
l6:6:wait:/etc/rc.d/rc.halt reboot

si::sysinit:/etc/rc.d/rc.sysinit

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -h now

# Run gettys in standard runlevels
#1:2345:respawn:/sbin/agetty 38400 tty1
#2:2345:respawn:/sbin/agetty 38400 tty2
#3:2345:respawn:/sbin/agetty 38400 tty3
#4:2345:respawn:/sbin/agetty 38400 tty4
#5:2345:respawn:/sbin/agetty 38400 tty5
#6:2345:respawn:/sbin/agetty 38400 tty5
S0:2345:respawn:/sbin/agetty ttyS0 19200 vt100
----------------------------------------------------------------------------
-----

Modify /etc/profile (to use term VT100 with file termcap)
Code:
----------------------------------------------------------------------------
-----
# /etc/profile

# System wide environment and startup programs
# Functions and aliases go in /etc/bashrc

PATH="$PATH:/sbin:/usr/sbin"
export TERM=vt100
ulimit -c 1000000
if [ `id -gn` = `id -un` -a `id -u` -gt 14 ]; then
   umask 002
else
   umask 022
fi

USER=`id -un`
LOGNAME=$USER

HOSTNAME=`/bin/hostname`
HISTSIZE=1000

if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]; then
   INPUTRC=/etc/inputrc
fi

export PATH USER LOGNAME HOSTNAME HISTSIZE INPUTRC

for i in /etc/profile.d/*.sh ; do
   if [ -x $i ]; then
      . $i
   fi
done

unset i
----------------------------------------------------------------------------
-----

I did lilo -t -v which was Ok, and then lilo was ok too
When I boot the system I have the lilo startup, then de Smothwall loading
(Smoothwall....................) then no more, I can't see the boot process,
but the SmoothWall is booting right then I have the prompt logon.

When I log on, its work fin I can make the entire task I want with my
terminal, I can read the /var/log/dmesg and I did not found any error about
ttyS0 

I tried to modify lilo.conf with other append section like only
console=ttyS0,19200n8 but it still not work
Can anyone can help me to see the boot process like I have in my
/var/log/dmesg:
----------------------------------------------------------------------------
-----
Linux version 2.6.16.53 (root at build) (gcc version 3.3.5) #1 Thu Aug 16
12:34:52 BST 2007
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 0000000010000000 (usable)
BIOS-e820: 00000000fff00000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
256MB LOWMEM available.
On node 0 totalpages: 65536
  DMA zone: 4096 pages, LIFO batch:0
  DMA32 zone: 0 pages, LIFO batch:0
  Normal zone: 61440 pages, LIFO batch:15
  HighMem zone: 0 pages, LIFO batch:0
DMI not present or invalid.
Allocating PCI resources starting at 20000000 (gap: 10000000:eff00000)
Built 1 zonelists
Kernel command line: auto BOOT_IMAGE=SmoothWall_S0 ro root=304
console=ttyS0,19200n8 ramdisk_size=8192 no-scroll panic=30
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Detected 433.325 MHz processor.
Using tsc for high-res timesource
Console: colour dummy device 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 256168k/262144k available (1507k kernel code, 5508k reserved, 706k
data, 200k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 868.60 BogoMIPS
(lpj=1737217)
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0088a93d c0c0a13d 00000000 00000000
00000000 00000000 00000000
CPU: After vendor identify, caps: 0088a93d c0c0a13d 00000000 00000000
00000000 00000000 00000000
CPU: L1 I Cache: 64K (32 bytes/line), D cache 64K (32 bytes/line)
CPU: L2 Cache: 128K (32 bytes/line)
CPU: After all inits, caps: 0088a93d c0c0a13d 00000000 00000000 00000000
00000000 00000000
CPU: AMD Geode(TM) Integrated Processor by AMD PCS stepping 02
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
checking if image is initramfs...it isn't (no cpio magic); looks like an
initrd
Freeing initrd memory: 437k freed
NET: Registered protocol family 16
EISA bus registered
PCI: PCI BIOS revision 2.01 entry at 0xfac61, last bus=0
PCI: Using configuration type 1
SCSI subsystem initialized
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
NET: Registered protocol family 8
NET: Registered protocol family 20
apm: BIOS not found.
io scheduler noop registered
io scheduler anticipatory registered (default)
io scheduler deadline registered
io scheduler cfq registered
Generic RTC Driver v1.07
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
floppy0: no floppy controllers found
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
loop: loaded (max 8 devices)
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
AMD5536: IDE controller at PCI slot 0000:00:14.2
AMD5536: chipset revision 1
AMD5536: not 100% native mode: will probe irqs later
AMD5536: 0000:00:14.2 (rev 01) UDMA100 controller
    ide0: BM-DMA at 0xe000-0xe007, BIOS settings: hda:pio, hdb:pio
Probing IDE interface ide0...
hda: ST980815A, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hda: max request size: 512KiB
hda: 156301488 sectors (80026 MB) w/8192KiB Cache, CHS=16383/255/63
hda: cache flushes supported
hda: hda1 hda2 hda3 hda4
mice: PS/2 mouse device common for all mice
input: PC Speaker as /class/input/input0
EISA: Probing bus 0 at eisa.0
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 4, 65536 bytes)
TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
klips_info:ipsec_init: KLIPS startup, Openswan KLIPS IPsec stack version:
cvs2002Mar12_00:19:03
NET: Registered protocol family 15
klips_info:ipsec_alg_init: KLIPS alg v=0.8.1-0 (EALG_MAX=255, AALG_MAX=251)
klips_info:ipsec_alg_init: calling ipsec_alg_static_init()
ipsec_aes_init(alg_type=15 alg_id=12 name=aes): ret=0
ipsec_aes_init(alg_type=14 alg_id=9 name=aes_mac): ret=0
ipsec_3des_init(alg_type=15 alg_id=3 name=3des): ret=0
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI Shortcut mode
RAMDISK: Compressed image found at block 0
EXT2-fs warning: checktime reached, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Trying to move old root to /initrd ... /initrd does not exist. Ignored.
Unmounting old root
Trying to free ramdisk memory ... okay
Freeing unused kernel memory: 200k freed
Warning: unable to open an initial console.
EXT3 FS on hda4, internal journal
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda3, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
Adding 650624k swap on /dev/harddisk2.  Priority:-1 extents:1 across:650624k
usbcore: registered new driver usbfs
usbcore: registered new driver hub
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
PCI: Setting latency timer of device 0000:00:15.0 to 64
ohci_hcd 0000:00:15.0: OHCI Host Controller
ohci_hcd 0000:00:15.0: new USB bus registered, assigned bus number 1
ohci_hcd 0000:00:15.0: irq 15, io mem 0xa0005000
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 4 ports detected
USB Universal Host Controller Interface driver v2.3
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
CSLIP: code copyright 1989 Regents of the University of California
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
ip_conntrack version 2.4 (2048 buckets, 16384 max) - 232 bytes per conntrack
IPP2P v0.8.2 loading
ip_conntrack_pptp version 3.1 loaded
ip_nat_pptp version 3.0 loaded
via-rhine.c:v1.10-LK1.2.0-2.6 June-10-2004 Written by Donald Becker
eth0: VIA Rhine III (Management Adapter) at 0x1e100, 00:00:24:c9:ab:e8, IRQ
11.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
eth1: VIA Rhine III (Management Adapter) at 0x1e200, 00:00:24:c9:ab:e9, IRQ
5.
eth1: MII PHY found at address 1, status 0x7849 advertising 05e1 Link 0000.
eth2: VIA Rhine III (Management Adapter) at 0x1e300, 00:00:24:c9:ab:ea, IRQ
9.
eth2: MII PHY found at address 1, status 0x7849 advertising 05e1 Link 0000.
eth3: VIA Rhine III (Management Adapter) at 0x1e400, 00:00:24:c9:ab:eb, IRQ
12.
eth3: MII PHY found at address 1, status 0x786d advertising 05e1 Link 41e1.
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth1: link down
eth2: link down
eth3: link up, 100Mbps, full-duplex, lpa 0x41E1

----------------------------------------------------------------------------
-----

Greetings
++




More information about the Soekris-tech mailing list