[Soekris] Unable to install FreeBSD on 4801 via PXE/TFTP

Tom Mazzotta tmazzotta at titanmicro.com
Thu Jul 26 03:09:17 UTC 2007


Just a followup on the PXE/TFTP boot problems I wrote about yesterday. After a lot of experimenting I found (by accident) that my 4801 would boot using only TFTP (w/o NFS). However, it only work occasionally! To get it to work, I needed to configure the default boot device to "F0" (ethernet port) using "set bootdrive=F0 80 81" in the combios. (Previously, I was using the default boot device parameters and I would ^P to get the monitor screen and type "boot f0"). Anyway, after cycling to power on the unit anywhere from 6 or 7 to more than a dozen times, it would boot properly. The way I knew when it would work was by "pxe_open" values reported by the bootstrap loader. When I saw "pxe_open: gateway ip:  0.0.0.0", I know it was going to fail! However, on occasion, it would say "pxe_open: gateway ip:  192.168.168.1", which is the correct gateway address on my LAN, and in this instance it would boot correctly.

QUESTION #1 - Is this normal? Could there be a h/w problem w/ my 4801 or my LAN, etc...?

Then after going thru a standard FreeBSD install, I get the errors:
      ad0: setting up DMA failed
      ata0: FAILURE - NON aligned DMA transfer attempted

      Unable to find device node for /dev/ad0s1b in /dev
      The creation of the filesystem will be aborted.

QUESTION #2 - Did I fry my drive by cycling the power so many times, or might something else be wrong?

Thanks!
-tm
________________________________
From: Tom Mazzotta
Sent: Tuesday, July 24, 2007 11:09 PM
To: soekris-tech at lists.soekris.com
Subject: Unable to install FreeBSD on 4801 via PXE/TFTP

I have been trying to use the procedure on the ultradesic.com website to install FreeBSD 6.2 on to a net4801-60. I have basically tried 4 permutations of the install using the boot image file downloaded from Ultradesic vs. patching the standard bootonly ISO image w/ recompiled PXEBOOT, LOADER, and KERNEL files (all built according to the Ultradesic procedure and sample config's). I also tried using FreeBSD vs. Windows XPP (w/Tftpd32) as my DHCP/TFTP server. No success with any of the scenarios. Typically, the following is what I see:

comBIOS ver. 1.31  20070408  Copyright (C) 2000-2007 Soekris Engineering.
net4801
0256 Mbyte Memory                        CPU Geode SC1100 267 Mhz
Pri Mas  FUJITSU MHN2100AT               LBA Xlt 1024-255-63  9820 Mbyte
Slot   Vend Dev  ClassRev Cmd  Stat CL LT HT  Base1    Base2   Int
-------------------------------------------------------------------
0:00:0 1078 0001 06000000 0107 0280 00 00 00 00000000 00000000
0:06:0 100B 0020 02000000 0107 0290 00 3F 00 0000E101 A0000000 10
0:07:0 100B 0020 02000000 0107 0290 00 3F 00 0000E201 A0001000 10
0:08:0 100B 0020 02000000 0107 0290 00 3F 00 0000E301 A0002000 10
0:10:0 104C AC23 06040002 0107 0210 08 3F 01 00000000 00000000
0:18:2 100B 0502 01018001 0005 0280 00 00 00 00000000 00000000
0:19:0 0E11 A0F8 0C031008 0117 0280 08 38 00 A0003000 00000000 11
1:00:0 100B 0020 02000000 0107 0290 00 3F 00 0000D001 A4000000 05
1:01:0 100B 0020 02000000 0107 0290 00 3F 00 0000D101 A4001000 11

comBIOS Monitor.   Press ? for help.
> boot f0
NSC DP83815/DP83816 Fast Ethernet UNDI, v1.03
Copyright (C) 2002, 2003 National Semiconductor Corporation
All rights reserved.
Pre-boot eXecution Environment  PXE-2.0 (build 082)
Copyright (C) 1997-2000  Intel Corporation

CLIENT MAC ADDR: 00 00 24 C8 B4 F8
CLIENT IP: 192.168.168.11  MASK: 255.255.255.0  DHCP IP: 192.168.168.38
GATEWAY IP: 192.168.168.1
PXE Loader 1.00
Building the boot loader arguments
Relocating the loader and the BTX
Starting the BTX loader
Consoles: internal video/keyboard
BIOS drive C: is disk0
PXE version 2.1, real mode entry point @9e64:00f6
BIOS 639kB/261120kB available memory
FreeBSD/i386 bootstrap loader, Revision 1.1
(root at freebsd1.huntington.local<mailto:root at freebsd1.huntington.local>, Tue Jul 24 17:18:00 EDT 2007)
pxe_open: server addr: 192.168.168.38
pxe_open: server path: /pxeroot
pxe_open: gateway ip:  0.0.0.0
NFS MOUNT RPC error: 60
\
can't load 'kernel'
Type '?' for a list of commands, 'help' for more detailed help.
OK
-------
By examining the log from Tftp32, I can tell the PXEBOOT was sent to the box, but it doesn't get an further:

Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:00:24:C8:B4:F8 [24/07 23:05:12.250]
DHCP: proposed address 192.168.168.12 [24/07 23:05:14.468]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:00:24:C8:B4:F8 [24/07 23:05:14.468]
DHCP: proposed address 192.168.168.12 [24/07 23:05:15.984]
Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:00:24:C8:B4:F8 [24/07 23:05:18.421]
Previously allocated address 192.168.168.12 acked [24/07 23:05:20.468]
Connection received from 192.168.168.12 on port 2070 [24/07 23:05:20.781]
Read request for file <boot\pxeboot>. Mode octet [24/07 23:05:20.781]
OACK: <tsize=219136,> [24/07 23:05:20.781]
Using local port 1679 [24/07 23:05:20.781]
Peer returns ERROR <TFTP Aborted> -> aborting transfer [24/07 23:05:20.781]
Connection received from 192.168.168.12 on port 2071 [24/07 23:05:20.875]
Read request for file <boot\pxeboot>. Mode octet [24/07 23:05:20.875]
Using local port 1680 [24/07 23:05:20.875]
<boot\pxeboot>: sent 429 blks, 219136 bytes in 1 s. 0 blk resent [24/07 23:05:21.015]
Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:00:24:C8:B4:F8 [24/07 23:05:21.765]
DHCP: proposed address 192.168.168.12 [24/07 23:05:23.265]
Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:00:24:C8:B4:F8 [24/07 23:05:23.265]
Previously allocated address 192.168.168.12 acked [24/07 23:05:24.765]
-------

Since I am a newbie at this I'm not sure what to try next. Has anyone successfully used the Ultradesic procedure to install FreeBSD on a 4801 w/ comBIOS ver. 1.31? If so, what is the trick to getting it to work? Thanks in advance!

-tm


More information about the Soekris-tech mailing list