[Soekris] Problem with booting on a net4511

Stuart Henderson stu at spacehopper.org
Wed Oct 12 20:17:32 UTC 2005


--On 12 October 2005 12:05 -0700, Deling Ren wrote:

> Greetings! I have recently installed an OpenBSD 3.7 on a net4511
> using flashdist script. It works fine except that it has problem
> booting after a reset. Cold boot works fine. But if I reboot the
> machine, it automatically tries to boot off PXE without looking up
> the compact flash card. I tried to enter comBIOS monitor and issued
> command "boot", but it seems that the file system can't be found by
> the loader:
...
> Any suggestion will be appreciated!

If you're using a custom kernel, try generic.
Have you tried more than one brand of flashcard?

If that still fails, try a standard OpenBSD install onto a flash card 
(you don't need an especially expensive card to hold etc, bin and the 
kernel). PXE-boot is probably the simplest way.

If a standard install with the generic kernel still fails, maybe it's 
worthing posting to openbsd-misc with more information (including a 
complete dmesg - don't trim it).




More information about the Soekris-tech mailing list