[Soekris] Newbie Mistake with net4526?

Frank Cole fcole at coleinnovations.com
Fri Oct 7 01:41:42 UTC 2005


Hi Josh,

Once you write a file system and/or boot loader to the internal CF card
comBIOS tries to boot from
it automagically.  To boot it after such an event do this:

1) Power it up.

2) Hit Control-P within the 5 seconds to get to the boot monitor (the
comBIOS prompt)

3) To PXE boot (the DHCP/TFTP/NFS thing) type "boot f0" (thats a zero).

That should get you back to where you started.

By the way, I don't really recommend GRUB on the 4526/4826.

After you run fdisk on /dev/hda you will need to lay some sort of a
filesystem on /dev/hda1 before you starting putting files on there.
Something like mkdosfs or mke2fs. Then install the bootloader (GRUB, lilo,
syslinux, etc.)

cramfs.img is really meant to be a file on a filesystem and loaded into ram
at boot time not written to a disk partition.


Hope it helps....


Frank Cole


> -----Original Message-----
> From: soekris-tech-bounces at lists.soekris.com 
> [mailto:soekris-tech-bounces at lists.soekris.com] On Behalf Of 
> Joshua ChaitinPollak
> Sent: Thursday, October 06, 2005 9:03 PM
> To: soekris-tech at lists.soekris.com
> Subject: [Soekris] Newbie Mistake with net4526?
> 
> Hello, I'm a bit of a newbie to single board computers, and I'm  
> afraid I may have made a critical mistake.
> 
> I'm trying to install Gentoo linux onto my 4526, and have been able  
> to get it to boot via DHCP/TFTP/NFS. I was trying to 
> configure a file  
> system for the flash rom, but apparently I don't know how it works.
> 
> I used fdisk /dev/hda and created a single partition using the whole  
> drive. I tried to install grub, but it failed, so created a cramfs  
> image and tried to install that to /dev/hda1 like this:
> 
> cat /cramfs.img > /dev/hda1
> 
> That seemed to work, so I tried to mount it, and saw this:
> 
> $ mount -t cramfs /dev/hda1 /mnt/
> mount: Mounting /deva/hda1 on /mnt failed: No such device
> 
> Thinking I needed to have the kernel re-load the partition table, I  
> power cycled the board. Now comBIOS Monitor counts down for 5  
> seconds, but the PXE Bootloader doesn't start. I was under the  
> impression that boot loader wasn't on the flash, but I guess I was  
> wrong.
> 
> How can I recover my board? After I do, how do I get a 
> bootloader and  
> root file system onto it safely?
> 
> I hope someone can help!
> 
> Thanks a lot,
> 
> -Josh
> 
> _______________________________________________
> Soekris-tech mailing list
> Soekris-tech at lists.soekris.com
> http://lists.soekris.com/mailman/listinfo/soekris-tech
> 
> 




More information about the Soekris-tech mailing list