[Soekris] 4501 or CF problem??

Ing Luděk Svoboda lusvobus at seznam.cz
Wed Jun 8 13:48:08 UTC 2005


Hello,
I have serious problem with booting 4501 from CF.
About 50% of reboots (hard or soft) works fine and 4501 boots from CF correctly,
but other 50% of reboots the 4501 can't boot from CF and stops with

"No Boot device available"

I tried to manually boot from monitor with 'boot' command or 'boot 80' command with no result.
Only next soft ('reboot' from monitor) or hard (pressing the reset button) can give next chance
to boot.

I tried different CF cards, 
for example:
Kingston 512MB - works fine
Kingston 128MB - has booting problems
Kingston 256MB - has booting problems
SanDisk ultra 128MB - works fine
SanDisk 256MB - has booting problems
Viking 128MB - works fine
very old noname 8MB - works fine

Any of them with the same OS and configuration but for example Kingston 512MB works fine but 
Kingston 256MB doesn't or SanDisk 256MB doesn't.

I read that some CF have booting problems, but doesn't find any 
reliable solution. 

I tried bios 1.26a and 1.28 with the same results. No difference.
I use the 4501 without any PCI or miniPCI card, only with CF, so i thing the 1A or 1.5A supply is good
for this.

It's very terrible for me, because I bought many different CF cards and didn't find any manufacturer,
which CF cards work good. 
I read that SanDisk CF cards are good, but just SanDisk 256MB doesn't work in my 4501.

Where is the problem?
In 4501 board, comBIOS or CF or power supply?

Thanks very much
____________________________________________________________
http://www.listicka.cz



More information about the Soekris-tech mailing list