[Soekris] Fedora C4 Grub Woes

Robert Brady rpbrady at gmail.com
Thu Jul 7 17:42:10 UTC 2005


I am having difficulty booting a Fedora Core 4 from a 512MB flash on
the net4501.  I am able to go from the comBios to grub, but after I
enter the root, kernel, and initrd lines into grub, I get
"Post0123456789abcde..." and then dumped right back into the comBios
again.  No error messages are returned.  It will cycle from comBios to
grub and then back to comBios.

I installed Fedora Core 4 following a procedure similar to that given at:
http://www.xs4all.nl/~vhouten/Soekris.html

However, my install was done on another partition of my laptop's
primary hda, then tested out to be sure it worked ok with ro root and
tmpfs /var.  It booted and worked fine.  I then changed the /etc/fstab
for a /dev/hda1 root and altered /etc/inittab for only a serial
terminal, as in the above link.  The I ported to the flash card as
follows:

1) fdisk my 512MB flash on /dev/sda of laptop, made 1 bootable linux
83 partition
2) mkfs.ext2 /dev/sda1
3) mount -t ext2 /dev/sda1 /mnt/cf
4) mount -t ext2 /dev/hda4 /mnt/miniFC4 (partition of the mini Fedora C4 root)
5) cd /mnt/miniFC4; cp -a * /mnt/cf (copy everything over to flash)
6) add "(hd1) /dev/sda" to /boot/grub/device.map so grub finds flash card
7) grub-install --root-directory=/mnt/cf /dev/sda
8) grub; grub> root (hd1,0); grub> setup (hd1);  succeeded on flash card
9) put flash card into net4501, power up, after comBIOS, I do this in
minicom of laptop

grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83

grub> kernel /boot/vmlinuz root=LABEL=/ console=ttyS0,9600n81
   [Linux-bzImage, setup=0x1e00, size=0x18e473]

grub> initrd /boot/initrd.img
   [Linux-initrd @ 0x3edb000, 0x114c03 bytes]

grub> boot

It looks like the net4501 is finding my root, kernel, and init images.
 I just don't understand why after the boot command that it drops me
back to the comBios.  There are no error messages after "boot", just a
line print out of "Post01234..." and them comBios reads cycles through
its memory counter.

Any advice appreciated.  Anybody solve this type of problem before? 
The Fedora C4 I have is about 360MB, read-only root, writes to tmpfs,
works great on the laptop.



More information about the Soekris-tech mailing list