[Soekris] 4801 dead console at boot

der Mouse mouse at Rodents.Montreal.QC.CA
Wed Apr 27 02:30:58 UTC 2005


I hate to post without lurking for a while, but (a) I skimmed the
archives and the list looks not too different from what I expected, and
(b) from my first seeing the box to my needing to post was short enough
that I didn't have much chance to do the lurk thing. :-/

I'm trying to deal with NetBSD on a 4801, using a Kingston CF/128
"128MB" (really 122.25MB) compact flash as "disk".  There are two
problems, one which I've worked around and the other which is still a
problem.

The first, the one I've worked around, is that the default bootblock
console selection doesn't work.  When I let the bootblocks inherit the
BIOS console (ie, no options to installboot when setting up the image),
the machine appears to wedge immediately upon loading the kernel, even
before the copyright message.  This I've "fixed" by explicitly telling
the bootblocks to use com0 as console (ie, installboot -o console=com0).

The other one is that the countdown to boot doesn't delay.  I've
checked the serial data stream, and the countdown is being performed,
but it's being done so fast that it's useless - it blows past the count
and goes on to boot far faster than I can react and interrupt it.  Is
this something I've done wrong, or not done, or is this facility just
busted on this hardware?

In passing, a suggestion to Soekris - maybe provide pre-rolled config
files for the various boxes, for some selection of OS releases?  If
this is already being done, they're sufficiently well hidden that I
failed to find them....

/~\ The ASCII				der Mouse
\ / Ribbon Campaign
 X  Against HTML	       mouse at rodents.montreal.qc.ca
/ \ Email!	     7D C8 61 52 5D E7 2D 39  4E F1 31 3E E8 B3 27 4B



More information about the Soekris-tech mailing list