[Soekris] 4801 CF + HD combo and OpenBSD

Lawrence Teo lteo_list at hotmail.com
Mon Jan 5 00:05:17 UTC 2004


First of all, I'm a total newbie when it comes to Soekris appliances.
I just tried installing a brand new hard drive on the net4801 with
OpenBSD 3.4, and encountered similar problems like those discussed
earlier on the list. My current setup is a CF card with OpenBSD 3.4
(including bsd.rd) and a blank Fujitsu 40GB hard drive (MHT2040AT).

At times, I've managed to get the net4801 BIOS to recognize the hard drive,
but when it does, the CF either doesn't boot or OpenBSD 3.4's bsd.rd does
not detect the drive. I have not found the ideal combination of 
configuration
parameters yet (set flash=primary/secondary, booting with bsd.rd, hard drive
jumpered to CS or slave, etc.).

Before I organize my results and spill out all the gory details, I just have
a simple question for now:

Does a completely brand new and empty hard drive need to be initialized
in any way in order for OpenBSD (bsd.rd) to recognize it?

If anyone has any information on this, or would like to suggest a 
combination
of configuration parameters that worked for you, I would really appreciate 
it.

Thanks,
Lawrence

Peter Curran wrote:
>Wolfgang
>
>Hmm
>
>You are getting some of the same problems as me.
>
>I also tried jumpering CS, set flash=secondary and then installing using 
>the BIOS geometry as reported by the 4801.
>
>This actually worked, but it took absolutely ages to boot the OS.  (The 
>little widger took up to 20 seconds to change position, rather than just 
>spinning around as normal.).
>
>I put this down to an LBA translation issue as the 4801 geometry was pretty 
>crude and only mapped 50% of the drive.
>
>In the end I went for a compromise...
>
>I stuck a copy of bsd.rd-a.out on a CF; set the jumper on the drive to 
>SLAVE; booted from the CF and loaded the bsd.rd-a.out image and then 
>installed via FTP onto the drive and the CF (using CFfor a small root 
>partition). [I used the a.out version because the CF had OpenBSD 3.3 on it 
>and it can't boot an ELF image].
>
>This works OK and will do for what I want at the moment - but there is 
>clearly something wierd going on as the boot from the HD (with CS) showed 
>up the CF as wd1, but the boot from the CF (with CS) did not show up the HD 
>as wd1.
>
>Sorry I can't help more with your issue - but try the above and it may get 
>you going.
>
>Cheers
>
>Peter

_________________________________________________________________
Check your PC for viruses with the FREE McAfee online computer scan.  
http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963




More information about the Soekris-tech mailing list