[Soekris] "wi0: wi_cmd failed with 60" on net4511 w/ OpenBSD -current

Jim Thompson jim at netgate.com
Wed Dec 24 15:15:19 UTC 2003


I suspect the miniPCI socket on your soekris board.

Until you said the miniPCI card worked fine in another box, I
suspected the card (and was going to offer to RMA it for you.)

Its also possible that you've got a little bit of driver skew between
the two boxes, and that is the source of your trouble.

Jim

Jon Hart writes:
> Hi there,
> 
> I'm posting here in the hopes that someone here has encountered this
> before.  Actually, I know people have encountered this before (based on
> searches of both the soekris-tech and openbsd lists), but nobody seems
> to have really found a solution.
> 
> I've got a Soekris Net4511 running openbsd -current as of about a week
> or so ago.  Its really a trimmed down of openbsd courtesy of my modified
> version of opensoekris.  It has a Engenius NL-2511CD Plus EXT2 with 2
> 5dbi omni antenae courtesy of netgate.com and is acting as the AP for my
> network (802.11b, 11mb, no wep).  After a day or so of operation, the
> wireless network died and I found the following messages on the console
> of the soekris box:
> 	
> 	wi0: wi_mgmt_xmit: xmit failed
> 	wi0: wi_cmd failed with 60
> 
> I tried some obvious things like fiddling with wicontrol, but the output
> of that was completely bogus.  The only solution was to reboot the box.
> Sometimes this worked.  Othertimes it didn't work at all.  In fact,
> sometimes after a reboot the card wouldn't even show up at all.  I'd
> halt the box, remove the power cable, plug it back in and wi0 wouldn't
> show up at all.  Other days I could surf wirelessly all day without
> issue, and then the problem would mysteriously pop up again.
> 
> Then I tried updating the bios of the 4511 from 1.15 to 1.15a and then
> to 1.22.  The problems seemed to go away.  I felt like I had conquered
> this problem.  Then it came back AGAIN.
> 
> I really don't think the wireless card is (entirely) to blame, because I
> can use it in another i386 OpenBSD ~-current box -- albeit not a soekris
> -- without any problems.  
> 
> If anyone has any pointers, that'd be most appreciated.  I've been
> maintaining the image for this soekris box on a fast openbsd box, so
> rebuilding the kernel or entire OS is not a problem.  
> 
> Here is a relevant portion of dmesg as taken from the most recent
> reboot:
> 
> wi0 at pcmcia0 function 0 "INTERSIL, HFA384x/IEEE, Version 01.02" port
> 0xa000/64
> wi0: PRISM2.5 ISL3873, Firmware 1.1.0 (primary), 1.4.9 (station),
> address 00:02:6f:08:0f:16
> wi0: init failed
> wi0: failed to allocate 1594 bytes on NIC
> wi0: tx buffer allocation failed
> wi0: failed to allocate 1594 bytes on NIC
> wi0: mgmt. buffer allocation failed
> 
> If it helps, I'm using the 12V DC / 110V AC 1.25A mini power supply.
> 
> Thanks in advance,
> 
> -jon
> 
> 
> _____________________________________________________________________
> Soekris Engineering, technical discussion mailing list
> [un]subscribe: http://lists.soekris.com/mailman/listinfo/soekris-tech
> 

-- 
"Speed, it seems to me, provides the one genuinely modern pleasure."
			-- Aldous Huxley (1894 - 1963)




More information about the Soekris-tech mailing list