[Soekris] net4801 - Linux boot?

Matt Dainty matt at bodgit-n-scarper.com
Sat Dec 6 23:41:50 UTC 2003


* Dave Johnson <dave-soekris-mailinglist at centerclick.org> [2003-12-06
23:33:52]:
> 
> > I tried your suggestion but it made no difference. (I guess I have
> > to update GRUB on my computer before I turn it off for tonight ;-).
> 
> Oh, you're trying to install the bootrecord from a PC not from the
> soekris box itself.  That's probably possible (though tricky as the
> devices aren't the same), but it's much easier to just boot the kernel
> via tftp then run lilo from the soekris box directly.

I think you're just missing this entry from your lilo.conf file:

disk=/dev/sda
        bios=0x80

Which when you write to the CF with the USB adapter, it'll know the CF
will actually be the first disk, (i.e. hda), when it boots.

Worked for me when I was playing with Linux on a net4501.

Matt
-- 
"A violent man will respond poorly to a gift of flowers."
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 186 bytes
Desc: not available
Url : http://lists.soekris.com/pipermail/soekris-tech/attachments/20031206/85103750/attachment.bin


More information about the Soekris-tech mailing list