[Soekris] Soekris boot - hangsup on /sbin/init - using lfs with glibc 2.3.2

Ravi ravivsn at roc.co.in
Mon Aug 4 15:40:22 UTC 2003


Hi Mathew,
Let me share my experience with you.
Network booting with pxe is a good idea and you can also try lilo on the 
flash.Recently I mailed the procedure to make CF up with lilo in this 
list.Go through that and build lfs.
Are you using busybox?
I suggest you compile the kernel for yourself (forget not to select elan 
processor ;) )and busybox instead reinventing the wheel.
Best Regards,
Ravi.


J.P. Mathew wrote:

> I got a Soekris 4521 last week and prepared an "lfs" system.
> I tested the Soekris with Mr. Mike Machado's 
> (www.innercite.com/~mike/soekris) lfs system, and was happy that the 
> Soekris booted up OK. But my own lfs system fails to load.
> Here is the description of the problem, and I will appreciate help in 
> solving the problem, or guiding me how to debug it further.
> 
> Problem: Compiled a full lfs system with current sources including glibc 
> 2.3.2, kernel 2.4.20 and gcc 3.2.3 using Ryan Oliver's notes on "pure 
> lfs" on the net.  I have used Mike Machado's  .config (since Mike's 
> system booted OK on the Soekris) and the new system loads perfectly on 
> my PC. But when I load it on the Soekris (using PXE boot), it hangsup on 
> loading /sbin/init. Initial boot messages are perfectly OK.
> 
> I used my kernel and Mike's  root file system (which uses libc-2.2.5-7 
> )- and that loads OK.
> I compiled "init"  static using my old glibc on the PC (from a RedHat 
> 8.0 installation) and just replaced that component alone, and the init 
> proceeds until the next executable that needs the shared library 
> (agetty) and it hangs there.
> 
> Problem seems to be with ld-2.3.2.so , but I am unable to debug it - not 
> knowing how to proceed. I have not seen any description of this problem 
> associated with ld-2.3.2.so and AMD Elan processor. Since this works OK 
> on Intel Pentium, I felt there could be some bug that shows up on 
> Elan/Soekris (I have 4521). I took a register dump just before 
> start_thread function call (both with Mike's file system and mine) and 
> it looks OK.
> 
> Appreciate it if anyone could throw some light on this. My current lfs 
> seems to be perfectly working on a PC, and I would like to fix the bug 
> with some help from the experts on this list, rather than go back to old 
> glibc, gcc version.
> Thanks a lot.
> 
> Joseph Mathew
> jpm at dps-india.com
> P.S. I am in Calcutta, India - hoping to create a new bunch of 
> enthusiasts here.
> 
> 
> 
> 
> 
> 
> _____________________________________________________________________
> Soekris Engineering, technical discussion mailing list
> [un]subscribe: http://lists.soekris.com/mailman/listinfo/soekris-tech
> 

-- 


The views presented in this mail are completely mine. The company is not
responsible for whatsoever.
------------------------------------------------------------------------
Ravi Kumar CH
Rendezvous On Chip (i) Pvt Ltd
Hyderabad, India
Ph: +91-40-2335 1214 / 1175 / 1184

ROC home page <http://www.roc.co.in>






More information about the Soekris-tech mailing list