[Soekris] Networking problems with 3com switches?

Aditya aditya at mighty.grot.org
Tue Jun 18 19:28:50 UTC 2002


Do you have flow control turned on on the switch? if so, try turning it off.

Did you try forcing 100baseTX full-duplex on both the net4501 and the
Superstack?

If neither of the above help, what OS are you running on your net4501?

Adi

On Tue, Jun 18, 2002 at 09:06:49PM +0200, Manuel Kasper wrote:
> Hi all,
> 
> I've been running a net4501 connected to a small D-Link 10/100 switch
> for several weeks at 100 Mbps, full duplex. I have now bought a new 3com
> SuperStack 3 Baseline 24-port 10/100 switch (that's an unmanaged one,
> BTW) because I was running out of ports. When I got everything
> connected, I soon noticed that the traffic LED on the switch port where
> the net4501 was connected was constantly flashing in a random pattern,
> although there was no traffic passing through it (the activity LED on
> the net4501 did not flash, either). All of a sudden I was getting bad
> throughput (e.g. 170 KBs go through at once, then it stops for 2 seconds
> or so, a few hundred KBs again, wait, and so on).
> 
> I have already tried power cycling everything several times, as well as
> exchanging the cable and using the two other network ports on the
> net4501 - same result. Forcing half duplex does not help, either,
> however, if I force 10 Mbps, the traffic LED stops flashing and
> throughput is normal for 10 Mbps again. I have also tried using other
> ports on the switch - no matter where I plug it in, it's always the
> same. All my other devices work without any problems at 100 Mbps, full
> duplex, so I don't think it's the switch's problem. Interestingly, if I
> hook up the net4501 to my old D-Link switch and connect that one to my
> new 3com switch, everything's OK.
> 
> The switch has Auto-MDI/MDI-X, and sometimes when I plug the net4501 in,
> it takes a long time (say about 20 seconds) to establish the link.
> During that period, the link lamp on the net4501 flashes slowly (switch
> trying MDI/MDI-X?).
> 
> Has anybody experienced similar problems or have an idea what the cause
> for this problem could be? My temporary solution is to simply run it at
> 10 Mbps, but... well... that's just not the way it should be. :(
> 
> Thanks,
> 
> Manuel
> 
> _____________________________________________________________________
> Soekris Engineering, technical discussion mailing list
> [un]subscribe: http://lists.soekris.com/mailman/listinfo/soekris-tech



More information about the Soekris-tech mailing list