[Soekris] trouble connecting via serial port

Chris Cappuccio chris at nmedia.net
Wed Jul 24 00:58:53 UTC 2002


set carrier-watch off

should work with a recent version of kermit

or just use cu -l /dev/blah -s 19200

Kurt Lieber [soekris at kirpatrick.com] wrote:
> I'm having a heck of a time connecting to my 4501 via the serial port.  I've 
> tried two separate null modem cables (one that I bought brand new since I 
> thought that was the problem) and a myriad of settings, but have had no 
> luck.
> 
> I'm using kermit on Gentoo linux as the host.  I type the following as root:
> 
> # kermit
> C-kermit>set line /dev/tts/0
> C-kermit>set speed 19200
> C-kermit>connect
> 
> Kermit then complains about no carrier being detected.  I can set 
> carrier-watch off, but that doesn't help, either.  Tried /dev/tts/1 -- no 
> luck.  (both devices exist)
> 
> I may have the OS (debian) screwed up on the CF card in the 4501, but I 
> would at least expect to see *something* via the serial connection.  (BIOS 
> screen, error message, blinking cursor, etc.)
> 
> It's been ages since I've connected to a device via a serial connection, so 
> I'm fairly sure I'm doing Something Stupid.  I just don't know what.
> 
> Any help?
> 
> --kurt
> _____________________________________________________________________
> Soekris Engineering, technical discussion mailing list
> [un]subscribe: http://lists.soekris.com/mailman/listinfo/soekris-tech



More information about the Soekris-tech mailing list