[Soekris] trouble connecting via serial port

Kurt Lieber soekris at kirpatrick.com
Tue Jul 23 22:34:32 UTC 2002


I'm having a heck of a time connecting to my 4501 via the serial port.  I've 
tried two separate null modem cables (one that I bought brand new since I 
thought that was the problem) and a myriad of settings, but have had no 
luck.

I'm using kermit on Gentoo linux as the host.  I type the following as root:

# kermit
C-kermit>set line /dev/tts/0
C-kermit>set speed 19200
C-kermit>connect

Kermit then complains about no carrier being detected.  I can set 
carrier-watch off, but that doesn't help, either.  Tried /dev/tts/1 -- no 
luck.  (both devices exist)

I may have the OS (debian) screwed up on the CF card in the 4501, but I 
would at least expect to see *something* via the serial connection.  (BIOS 
screen, error message, blinking cursor, etc.)

It's been ages since I've connected to a device via a serial connection, so 
I'm fairly sure I'm doing Something Stupid.  I just don't know what.

Any help?

--kurt



More information about the Soekris-tech mailing list