[Soekris] linux on the net4501

skmail@mcewen.wcnet.org skmail at mcewen.wcnet.org
Mon Apr 8 20:57:58 UTC 2002


Hi all-

I am building a little firewall out of the net4501.  I have taken a RedHat
Linux 7.2 based system and removed all the junk, installed tinylogin and
busybox, and shrunk it down to about 20 megs.  It's going to run on a read
only flash disk, with anything that required read-write being placed in
ramdisk.  I'm trying to use the latest stable kernel 2.4.18, and having a
hell of a time.  I tried with everything I need compiled in, and it gets
halfway through the booting process then dies at the message "freeing
unused kernel memory", with no error message.  Also tried with modules,
it's my first try with the modules so I may have accidently removed
something I needed, but it dies after "loading linux...".

I can take that flash module out, put it in a desktop machine and boot/run
from it, and it works perfectly every time.

For those of you running linux, what kernel versions are you all using?  
Or if someone could send me their .config file from a recent kernel that
does successfully boot so I can see what options you're using, that would 
be much appreciated.

Or is there some specific patch that I need to apply to the kernel for the
Elan processor that I don't know about?


Thanks for any help.  

Scot 




More information about the Soekris-tech mailing list